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UNICORE Exercises
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Prerequisites

The UNICORE Client is a Java Application that requires at least Java Run Time
Environment version 1.5 to be installed
¾ Check if the SUN-Java Runtime Environment version higher than 1.5 is installed on
your computer
o On MS Windows type java -version in a DOS box
o On UNIX/Linux type java –version in a console
¾ If the execution of the command fails or if you have a java version older than 1.5 go to the
SUN web page to download and install the latest JRE 1.5.x on your local computer, following
the instructions given there.
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Prepare and configure the Client

2.1

Install the Client
¾ Go to http://www.unicore.eu -> Download
¾ Change to UNICORE 5
¾ Download client_5.6.6_installer.jar from
Core -> Client ->Download
¾ Execute the installer and start the client
Linux:
¾ Open a console and type
java –jar client_5.6.6_installer.jar
¾ Start client via:
cd ~/UNICORE/bin
./unicore &
Windows:
¾ Double-click on client_5.6.6_installer.jar
¾ by double clicking on the UNICORE desktop symbol or execute the file
UNICORE\bin\unicore.bat
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¾ A warning might occur that some unicorepro UNICORE site is not available.
o Confirm with OK
¾ Confirm creation of a new UNICORE keystore and choose a password.
¾
¾ The UNICORE password checking is quite strict so a warning might appear. Click on ->
OK

2.2

Import private certificate keystore (.pkcs12)
¾ Prerequisites: you have got already a signed certificate from your national CA and the
corresponding .pkcs12 file on your local computer. Assuming this is called user1.p12
¾ Select Settings -> Keystore Editor, Action -> Import Keystore in the UNICORE client and
select user1.p12 within the upcoming filebrowser
¾ Provide your password the user1.p12 is encrypted with
¾ Click OK. Your user certificate will be shown in the list of Key entries. If there is a
problem you will be informed, otherwise you won't get any message
¾ Mark your certificate and click on Details. They should look similar to the example.

¾ Download the EU-GridPMA certificates from http://winnetou.sara.nl/deisa/certs
-> Package with individual certs from CAcerts file in zip (gz) format ->unicerts.zip
(unicerts.tar.gz)
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¾ Extract the certificates to a local folder
¾ Import the EU-GridPMA certificates (only the .pem-files)with the UNICORE Keystore
Editor
¾ choose from the menu Action -> Import Certificate and select all stored certificates

¾ Confirm with OK
¾ Save your keystore: File -> Save.
¾ Exit the keystore: File->Exit

2.3

Make DEISA Gateways known to the client
¾
¾
¾
¾

Select Settings -> User Defaults -> General->URL(s) for UNICORE Site Server
Remove the existing URL (if any)
Type http://www.fz-juelich.de/unicore/unicoreSites_DEISA.xml in this field
confirm with OK
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2.4

Refresh the actual settings
To refresh the actual settings of the UNICORE client with the actual configuration, select
Settings -> Clear Cache
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Using the Client

3.1

Run a simple script
¾ Select from the menu of the UNICORE client File -> New Job.
¾ Select your DEISA Home Site (UNICORE Site e.g. DEISA_CINECA) and a Virtual
Site (e.g. FZJ JUMP)
o Important note: BSC Marenostrum, ECMWF and HLRS_NEC_SX8 are not
available for the training session use!
¾ Select Job Preparation -> Add Script
¾ Type a simple bash script in the UNICORE script editor

¾ Right-click on the job and choose Submit or click on
The job will be submitted to the supercomputer of your Home site.
¾ Right-click on the target system the job has been submitted to in the lower left Job
Monitoring window and choose Refresh or click on
You should see your job now
coloured in yellow (indicating that the job is queued), red (indicating that the job has been
failed) or green (indicating that the job has run successfully).
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Right-click on the job in the lower left window and choose Fetch output or click on
the right part of the screen you should now see the output of your script.

3.2

. In

Hold, resume, and abort a job
¾ To create a job that runs a little longer, add to the script sleep 20 and submit
the job as before. Right-click on the target system in the Job Monitoring Window
and choose Refresh. You should see your second job coloured in yellow and blue,
indicating that the job is being executed/run. Right-click on the job and choose
Hold Job. Then right-click on the job and choose Resume Job. You can try Abort
Job (after job is hold) as well.

3.3

File import
¾ Create an arbitrary text file foo.txt. Create a new job (File -> New Job)
and select a site where it should run.
¾ Select Job Preparation-> Add Import. In the right part of the screen, click on the leftmost
icon to create a new file entry
o In the first column, choose e.g. Local
o Choose the file to import from the UNICORE file browser
Or enter the
complete path to your text file (e.g. /home/deisa111/foo.txt) into the second
column.
o In the third column enter the new name of the text file, use the same name foo.txt.

¾ To display the content of the imported file add a UNICORE script (Job Preparation->
Add Script) to the job with the following content:
cat foo.txt
¾ As it is, the script task and the import task would run independent of each other in
arbitrary order. But the script should be executed after the import has finished, so we have
to create a workflow:
¾ Click on the job and look at the blue window on the right hand side.
¾ Click on the file import with the right mouse button (don’t release the button yet) and drag
an arrow to the script.
¾ Now submit the job and fetch the output as above.
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3.4

If-then-else job
¾ Create a new file (foo2.txt) which is different from foo.txt
¾ Create a new job and select the Site where it should run. Add an import task as before (Job
Preparation-> Add File Import), but then create a task for both foo.txt and foo2.txt.
¾

Add a UNICORE script (Job Preparation-> Add Script) and name it diff_script
The script contains
diff foo.txt foo2.txt > diff_output
¾ To add an if-then-else task, select Job Preparation-> Add If Then Else.
¾ In the right part of the screen you can now configure the if-then-else task.
¾ In the uppermost part labelled ”Return Code Test” choose from the first drop down menu
return code equals and leave the according value at zero.
¾ From the second drop down menu choose diff_script.

diff_script

¾ The if-then-else task has two sub jobs: Then and Else.
o Select the Then-part and add a script Job Preparation-> Add Script.
o Enter: echo "Files are equal!" in the UNICORE script editor
o Add a script to the Else-part as well with the following content:
echo "Files differ!"
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¾ Now go to the workflow edit window and drag an arrow from the Import Task to the diff
script and from the diff script to the If-Then-Else-Task. Submit your job.
¾ If the files are different UNICORE’s diff_script task will be red. That is because
in this case the diff command returns “1” and UNICORE interprets the return values with
different colours. It doesn’t mean that there is a UNICORE error.

3.5

File export
¾ Add an export task to the above job (Job Preparation-> Add Export)
¾ Create a new entry and enter diff_output in the first column. Choose Local from the
drop down menu, browse the file system with
and enter something like
diff_output as file name in the third column. If you want to run the job
multiple times, select “Overwrite File(s)” as well.
¾ In the workflow editor, drag an arrow from the if-then-else task to the file
export task.
¾ Submit your job. You should now have a copy of diff_output with the output of your
diff-script on your local workstation

3.6

DEISA GPFS and UNICORE
This example is to show the functionality and strength of DEISA GPFS within UNICORE.
Step 1:
¾ Create a new UNICORE workflow with File->New Job
¾ Rename the job to “DEISA_job”
¾ Select your Home site as UNICORE Site (e.g. DEISA_CINECA for the CINECA users)
and the Virtual Site FZJ JUMP
¾ Click on “DEISA_job”
¾ Add a sub job to the job (Job Preparation->Add Sub Job)
¾ Rename the first sub job from “New_Sub_Job1” to “IDRIS”
¾ Click on “IDRIS” and select your Home site as UNICORE Site and the Virtual Site
IDRIS ZAHIR. This means that this subjob will be executed on the IDRIS supercomputer
¾ Click on “IDRIS” and select Job Preparation->Add Script
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¾ Rename the script from “New_Sctript1” to “start_at_IDRIS”
¾ Enter the following script:

Step 2:
¾
¾
¾
¾

Click on “DEISA_job”
Add a 2nd subjob to “DEISA_job” (Job Preparation->Add Sub Job)
Rename the 2nd sub job from “New_Sub_Job2” to “FZJ”
Click on “FZJ” and select your Home site as UNICORE Site and the Virtual Site FZJ
JUMP. This means that this 2nd sub job will be executed on the FZJ supercomputer
¾ Click on “FZJ” and select Job Preparation->Add Script
¾ Rename the script to “continue_at_FZJ”
¾ Enter the above script
Step 3:

¾
¾
¾
¾

Click on “DEISA_job”
Add a third subjob to “DEISA_job” (Job Preparation->Add Sub Job)
Rename the third sub job from “New_Sub_Job3” to “CINECA”
Click on “CINECA” and select your Home site as UNICORE Site and the Virtual Site
CINECA-SP5. This means that this third subjob will be executed on the CINECA
supercomputer
¾ Click on “CINECA” and select Job Preparation->Add Script
¾ Rename the script to “finish_at_CINECA”
¾ Enter the above script

Step 4:
¾
¾
¾
¾

Click on “DEISA_job”
Add a fourth sub job to “DEISA_job” (Job Preparation->Add Sub Job)
Rename the fourth sub job from “New_Sub_Job4” to “export”
Click on “export” and select your Home site as UNICORE Site and the Virtual Site
CINECA-SP5. This means that this fourth sub job will be executed on the CINECA
supercomputer again
¾ Click on “export” and select Job Preparation->Add Export
¾ Rename the new export task to “get_results”
o Create a new export task by clicking on
o Type in “File in Job Directory”: $DEISA_HOME/working
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o Choose as Destination: Local
o Mark “Overwrite Fiel(s)”
o Choose as “File at Destination” your local desktop directory
¾ Click on “DEISA_job” It should look as follows:
o (eventually click on the “DEISA_job” and press

¾ Now add dependencies in the workflow edit window and drag an arrow from the “IDRIS”task to the “FZJ”-task, from the “FZJ”-task to the ”CINECA”-task and from the
“CINECA”-task to the “export”-task to define the dependencies.
¾ Submit the job and fetch output as above.
¾ Have a look in the local copy of “working”. The data from all sites the job has been
submitted to should be available.
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Access the DCPE with UNICORE
¾ Create a new job with following script
module load deisa
cd $DEISA_HOME
pwd
ls
module list
module avail
¾ Create a new job with the following script:
module load deisa cpmd
module list
echo “CPMD-PATH:” $PATH
module unload cpmd
module list
echo “CPMD-PATH:” $PATH
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module load nag
module list
module load fftw
module list
echo $DEISA_FFLAGS
echo $DEISA_LDFLAGS
module switch fftw fftw/3
module list
echo $DEISA_FFLAGS
echo $DEISA_LDFLAGS
module whatis fortran
module help fortran
module display fortran
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Defining resources with UNICORE
¾ Mark the job and click on Resources in the upper right window
¾ Add a new resource set by clicking on
¾ Edit the resource set by clicking on
o The Resource Editor appears - enable the values you want to change by clicking in
the corresponding squares of the first row
o you can change the values by double clicking the Request row
o Your values have to be between the given Minimum and Maximum
o when you have finished editing the resource set click OK
o for each task in your job you can create an own resource set
o to merge the resource set with the corresponding task select the lower right Tasks
window and click on the task
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6

Hints for further usage

6.1

What site resources are available?
You can have a look at the resources of a site by clicking on the magnifying
glass next to the Vsites List. Next to the tab of the workflow editor you can find
a tab called ”Resources” where you can specify the requirements of your job.

6.2

Documentation and dissemination
http://www.unicore.eu
http://summit.unicore.org
For client functionality documentation you might open the Help -> Help -> User
Guide in the UNICORE client or go to
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